<!doctype html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link type="text/css" media="all" href="https://ameliaislandliving.com/fernandinabeach/wp-content/cache/autoptimize/autoptimize_0eecf3b48c53d4bf13553520d0d12dde.php" rel="stylesheet" /><link type="text/css" media="print" href="https://ameliaislandliving.com/fernandinabeach/wp-content/cache/autoptimize/autoptimize_3950ef1953883cc46c12ed28870e6767.php" rel="stylesheet" /><title>Rolling Stones&#039; Mick Jagger Dines Downtown At Espana | Amelia Island Living ©2019</title><meta name="description" content="The lead singer of the Rolling Stones had dinner in downtown Fernandina this week at Espana. Jagger is on tour, scheduled to perform July 19th at Jacksonville&#039;s TIAA Bank Field." /><link rel="canonical" href="https://ameliaislandliving.com/fernandinabeach/2019/07/rolling-stones-mick-jagger-dines-downtown-at-espana/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Rolling Stones&#039; Mick Jagger Dines Downtown At Espana | Amelia Island Living ©2019" /><meta property="og:description" content="The lead singer of the Rolling Stones had dinner in downtown Fernandina this week at Espana. Jagger is on tour, scheduled to perform July 19th at Jacksonville&#039;s TIAA Bank Field." /><meta property="og:url" content="https://ameliaislandliving.com/fernandinabeach/2019/07/rolling-stones-mick-jagger-dines-downtown-at-espana/" /><meta property="og:site_name" content="Amelia Island Living ©2019" /><meta property="article:publisher" content="https://www.facebook.com/AmeliaIslandLivingeMagazine/" /><meta property="article:tag" content="&quot;restaurants&quot;" /><meta property="article:tag" content="Amelia Island news" /><meta property="article:tag" content="dining" /><meta property="article:tag" content="Espana" /><meta property="article:tag" content="fernandina beach" /><meta property="article:tag" content="Mick Jagger" /><meta property="article:tag" content="Rolling Stones" /><meta property="article:section" content="Marketplace" /><meta property="article:published_time" content="2019-07-18T05:02:40+00:00" /><meta property="article:modified_time" content="2019-07-18T05:03:45+00:00" /><meta property="og:updated_time" content="2019-07-18T05:03:45+00:00" /><meta property="og:image" content="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown.png" /><meta property="og:image:secure_url" content="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown.png" /><meta property="og:image:width" content="1000" /><meta property="og:image:height" content="740" /><meta property="og:image:alt" content="Espana restaurant, Fernandina Beach dining, downtown historic district, Amelia Island, Florida." /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="The lead singer of the Rolling Stones had dinner in downtown Fernandina this week at Espana. Jagger is on tour, scheduled to perform July 19th at Jacksonville&#039;s TIAA Bank Field." /><meta name="twitter:title" content="Rolling Stones&#039; Mick Jagger Dines Downtown At Espana | Amelia Island Living ©2019" /><meta name="twitter:site" content="@florida32034" /><meta name="twitter:image" content="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown.png" /><meta name="twitter:creator" content="@florida32034" /> <script type='application/ld+json'>{"@context":"https://schema.org","@type":"Organization","url":"https://ameliaislandliving.com/fernandinabeach/","sameAs":["https://www.facebook.com/AmeliaIslandLivingeMagazine/","https://pinterest.com/seeameliaisland","https://twitter.com/florida32034"],"@id":"https://ameliaislandliving.com/fernandinabeach/#organization","name":"Amelia Island Living & Travel eMagazine","logo":"https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/01/amelia-island-living-travel-emagazine-sunrise-433.png"}</script> <script type='application/ld+json'>{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://ameliaislandliving.com/fernandinabeach/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://ameliaislandliving.com/fernandinabeach/2019/07/rolling-stones-mick-jagger-dines-downtown-at-espana/","name":"Rolling Stones&#8217; Mick Jagger Dines Downtown At Espana"}}]}</script> <link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Amelia Island Living ©2019 &raquo; Feed" href="https://ameliaislandliving.com/fernandinabeach/feed/" /><link rel="alternate" type="application/rss+xml" title="Amelia Island Living ©2019 &raquo; Comments Feed" href="https://ameliaislandliving.com/fernandinabeach/comments/feed/" /><link rel='stylesheet' id='dashicons-css' href="https://ameliaislandliving.com/fernandinabeach/wp-includes/css/dashicons.min.css?ver=5.2.2&amp;da0a76&amp;da0a76" type='text/css' media='all' /><link rel='https://api.w.org/' href='https://ameliaislandliving.com/fernandinabeach/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ameliaislandliving.com/fernandinabeach/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ameliaislandliving.com/fernandinabeach/wp-includes/wlwmanifest.xml?da0a76&amp;da0a76" /><meta name="generator" content="WordPress 5.2.2" /><link rel='shortlink' href='https://ameliaislandliving.com/fernandinabeach/?p=55615' /><link rel="alternate" type="application/json+oembed" href="https://ameliaislandliving.com/fernandinabeach/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fameliaislandliving.com%2Ffernandinabeach%2F2019%2F07%2Frolling-stones-mick-jagger-dines-downtown-at-espana%2F" /><link rel="alternate" type="text/xml+oembed" href="https://ameliaislandliving.com/fernandinabeach/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fameliaislandliving.com%2Ffernandinabeach%2F2019%2F07%2Frolling-stones-mick-jagger-dines-downtown-at-espana%2F&#038;format=xml" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-11941575-1', 'auto');
  ga('send', 'pageview');</script> <meta name="p:domain_verify" content="3888b30ef41bb35f614e0c1bbf8db15a" /><link rel="alternate" type="application/rss+xml" title="Stories" href="https://ameliaislandliving.com/fernandinabeach/feed/?post_type=amp_story"><link rel="amphtml" href="https://ameliaislandliving.com/fernandinabeach/2019/07/rolling-stones-mick-jagger-dines-downtown-at-espana/?amp"><link rel="icon" href="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/03/cropped-logo-sun-watercolor-only-amelia-island-4-32x32.png?da0a76&amp;da0a76" sizes="32x32" /><link rel="icon" href="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/03/cropped-logo-sun-watercolor-only-amelia-island-4-192x192.png?da0a76&amp;da0a76" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/03/cropped-logo-sun-watercolor-only-amelia-island-4-180x180.png?da0a76&amp;da0a76" /><meta name="msapplication-TileImage" content="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/03/cropped-logo-sun-watercolor-only-amelia-island-4-270x270.png" /></head><body class="post-template-default single single-post postid-55615 single-format-standard wp-custom-logo wp-embed-responsive singular"><div id="page" class="site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><header id="masthead" class="site-header featured-image"><div class="site-branding-container"><div class="site-branding"><div class="site-logo"><a href="https://ameliaislandliving.com/fernandinabeach/" class="custom-logo-link" rel="home"><img width="190" height="190" src="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/03/cropped-logo-sun-watercolor-only-amelia-island-3.png?da0a76&amp;da0a76" class="custom-logo" alt="Amelia Island Living ©2019" srcset="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/03/cropped-logo-sun-watercolor-only-amelia-island-3.png 190w, https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/03/cropped-logo-sun-watercolor-only-amelia-island-3-125x125.png 125w" sizes="(max-width: 190px) 100vw, 190px" /></a></div><p class="site-title"><a href="https://ameliaislandliving.com/fernandinabeach/" rel="home">Amelia Island Living ©2019</a></p><nav id="site-navigation" class="main-navigation" aria-label="Top Menu"><div class="menu-top-navigation-container"><ul id="menu-top-navigation" class="main-menu"><li id="menu-item-51535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51535"><a href="https://ameliaislandliving.com/fernandinabeach/topics/amelia-island-beach/">Beach News</a></li><li id="menu-item-51536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51536"><a href="https://ameliaislandliving.com/fernandinabeach/topics/downtown-fernandina/">Downtown Topics</a></li><li id="menu-item-40662" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40662"><a href="https://ameliaislandliving.com/fernandinabeach/topics/marketplace/">BIZ News</a></li><li id="menu-item-19041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19041"><a href="https://ameliaislandliving.com/fernandinabeach/topics/nature/">Nature</a></li><li id="menu-item-47958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47958"><a href="https://ameliaislandliving.com/fernandinabeach/topics/cumberland-island-georgia/">Cumberland</a></li><li id="menu-item-40661" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40661"><a href="https://ameliaislandliving.com/fernandinabeach/topics/garden/">Garden</a></li><li id="menu-item-51512" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51512"><a href="https://ameliaislandliving.com/fernandinabeach/topics/amelia-island-perspective/">Perspective</a></li><li id="menu-item-48687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48687"><a href="https://ameliaislandliving.com/fernandinabeach/topics/amelia-island-real-estate/">Real Estate</a></li></ul></div><div class="main-menu-more"><ul class="main-menu"><li class="menu-item menu-item-has-children"><button class="submenu-expand main-menu-more-toggle is-empty" tabindex="-1" aria-label="More" aria-haspopup="true" aria-expanded="false"><span class="screen-reader-text">More</span><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" width="24" height="24" xmlns="http://www.w3.org/2000/svg"><g fill="none" fill-rule="evenodd"><path d="M0 0h24v24H0z" /><path fill="currentColor" fill-rule="nonzero" d="M12 2c5.52 0 10 4.48 10 10s-4.48 10-10 10S2 17.52 2 12 6.48 2 12 2zM6 14a2 2 0 1 0 0-4 2 2 0 0 0 0 4zm6 0a2 2 0 1 0 0-4 2 2 0 0 0 0 4zm6 0a2 2 0 1 0 0-4 2 2 0 0 0 0 4z" /></g></svg></button><ul class="sub-menu hidden-links"><li id="menu-item--1" class="mobile-parent-nav-menu-item menu-item--1"><button class="menu-item-link-return"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M15.41 7.41L14 6l-6 6 6 6 1.41-1.41L10.83 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>Back</button></li></ul></li></ul></div></nav></div></div><div class="site-featured-image"><figure class="post-thumbnail"> <img width="1000" height="740" src="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown.png?da0a76&amp;da0a76" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Espana restaurant, Fernandina Beach dining, downtown historic district, Amelia Island, Florida." srcset="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown.png 1000w, https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown-169x125.png 169w, https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown-400x296.png 400w, https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown-768x568.png 768w, https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown-900x666.png 900w" sizes="(max-width: 1000px) 100vw, 1000px" /></figure><div class="entry-header"><h1 class="entry-title">Rolling Stones&#8217; Mick Jagger Dines Downtown At Espana</h1><div class="entry-meta"> <span class="byline"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 12c2.21 0 4-1.79 4-4s-1.79-4-4-4-4 1.79-4 4 1.79 4 4 4zm0 2c-2.67 0-8 1.34-8 4v2h16v-2c0-2.66-5.33-4-8-4z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg><span class="screen-reader-text">Posted by</span><span class="author vcard"><a class="url fn n" href="https://ameliaislandliving.com/fernandinabeach/author/polarbear/">Steve Nicklas</a></span></span> <span class="posted-on"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><defs><path id="a" d="M0 0h24v24H0V0z"></path></defs><clipPath id="b"><use xlink:href="#a" overflow="visible"></use></clipPath><path clip-path="url(#b)" d="M12 2C6.5 2 2 6.5 2 12s4.5 10 10 10 10-4.5 10-10S17.5 2 12 2zm4.2 14.2L11 13V7h1.5v5.2l4.5 2.7-.8 1.3z"></path></svg><a href="https://ameliaislandliving.com/fernandinabeach/2019/07/rolling-stones-mick-jagger-dines-downtown-at-espana/" rel="bookmark"><time class="entry-date published" datetime="2019-07-18T01:02:40-04:00">July 18, 2019</time><time class="updated" datetime="2019-07-18T01:03:45-04:00">July 18, 2019</time></a></span> <span class="comment-count"> </span></div></div></div></header><div id="content" class="site-content"><section id="primary" class="content-area"><main id="main" class="site-main"><article id="post-55615" class="post-55615 post type-post status-publish format-standard has-post-thumbnail hentry category-marketplace category-amelia-island-summer tag-restaurants tag-amelia-island-news tag-dining tag-espana tag-fernandina-beach tag-mick-jagger tag-rolling-stones entry"><div class="entry-content"><p> <em>Editor&#8217;s note: Contributing columnist, Steve Nicklas, expresses his views and insight on various topics in Marketplace column.</em></p><div class="wp-block-image"><figure class="aligncenter size-large"><img src="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown-mick-jagger-rolling-stones.png?da0a76&amp;da0a76" alt="Espana restaurant, Fernandina Beach dining, downtown historic district, Amelia Island, Florida." class="wp-image-55619" srcset="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown-mick-jagger-rolling-stones.png 700w, https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown-mick-jagger-rolling-stones-169x125.png 169w, https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2019/07/espana-restaurant-fernandina-beach-dining-downtown-mick-jagger-rolling-stones-400x296.png 400w" sizes="(max-width: 700px) 100vw, 700px" /></figure></div><h4>&#8211;Steve&#8217;s Marketplace&#8211;</h4><p>The always bustling crowd at Espana<strong> </strong>Restaurant had emptied out by 10 p.m. Tuesday night, when a phone call arrived. It was a request from the Ritz-Carlton Hotel to accommodate a special guest.</p><p><em>“They said it was a bigwig,” </em>recalled Espana owner Roberto Pestana. The bigwig turned out to be Mick Jagger, lead singer of the Rolling Stones – in town for a concert Friday night at TIAA Bank Field.</p><p><em>“It’s the highlight of my career,”</em> says Roberto, who has entertained other notable celebrities like Fergie. <em>“He was very approachable, very cool. There was nothing snooty about him.”</em></p><p>Jagger dined with a small group, downed a bottle of wine or two,
and chatted amiably with the Espana staff. But no photographs, or brown sugar
on the Portuguese cuisine.</p><p><em>“I was disappointed that I was not able to get a picture, but I respect his privacy,” </em>Roberto says. In fact, a couple of people who apparently had heard of Jagger’s presence tried to slip in and take a picture. But Jagger’s security guard would have none of it.</p><p>After dinner, Jagger’s manager took Roberto’s cell phone number to contact him directly next time. When they learned that Roberto’s wife, Marina, is going to the concert, they offered to upgrade her tickets. <em>“They were very respectable, honorable people,” </em>says Roberto.</p><p>In case any Stones&nbsp;fans are concerned about Jagger’s health following his heart surgery, Roberto says there is no need. <em>“He looked in fabulous shape,”</em> he says.</p><p>Fortunately for much of Amelia Island, Jagger and the Stones should put on one of their stellar shows. Roberto’s wife will enjoy it, but he has to work. It’s the life of an uber-successful restaurant owner.</p><p><em>“I heard like three-quarters of the island is going,”</em> Roberto says. <em>“I’ll turn out the lights when everybody leaves. I’ll be here by myself.</em></p><p>Amelia Island is becoming a playground for the famous. Jagger’s quiet appearance at Espana is the latest sighting. Faith Hill, Demi Moore, John Travolta and Michael Jackson have all been here.</p><p>And who can forget the frantic phone call that came in to Amelia
Dental Group just before the Super Bowl XXXIX in Jacksonville. They wouldn’t
say who needed dental work, just that it was urgent.</p><p>When Dr. Rob Van Etta showed up at the former Alltel Stadium, he
found in the dental chair none other than Paul McCartney, the halftime
entertainer. McCartney had a tooth ache.</p><p>Amelia Dental Group was on call for such emergencies. And the call
was routed to Van Etta, who kind of saved the show. Like with Roberto, it had
to be the highlight of his career.</p><div class="wp-block-image"><figure class="alignleft size-large"><img src="https://ameliaislandliving.com/fernandinabeach/wp-content/uploads/2015/01/stevenicklasheadshotameriprise-e1555356855636.jpg?da0a76&amp;da0a76" alt="Steve Nicklas Financial Advisor" class="wp-image-33474" /><figcaption>Steve Nicklas, Financial Advisor</figcaption></figure></div><p><em>Steve Nicklas,&nbsp;CRPC®,&nbsp;is a financial advisor with a U.S. brokerage firm who lives and works on Amelia Island. He is also an award-winning columnist. His columns regularly appear in weekly newspapers in North Florida and in South Georgia, and on his website at&nbsp;SteveNicklasMarketplace.com. He has published a book, “All About Money,” of his favorite columns from the past 20 years. The book is available at local stores and on Amazon. He can be reached at 904-753-0236 or at&nbsp;<a rel="noreferrer noopener" href="/cdn-cgi/l/email-protection#582c303d36313b3334392b2c3d39356a18352b36763b3735" target="_blank"><span class="__cf_email__" data-cfemail="3e4a565b50575d55525f4d4a5b5f530c7e534d50105d5153">[email&#160;protected]</span></a>.</em></p></div><footer class="entry-footer"> <span class="byline"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 12c2.21 0 4-1.79 4-4s-1.79-4-4-4-4 1.79-4 4 1.79 4 4 4zm0 2c-2.67 0-8 1.34-8 4v2h16v-2c0-2.66-5.33-4-8-4z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg><span class="screen-reader-text">Posted by</span><span class="author vcard"><a class="url fn n" href="https://ameliaislandliving.com/fernandinabeach/author/polarbear/">Steve Nicklas</a></span></span><span class="posted-on"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><defs><path id="a" d="M0 0h24v24H0V0z"></path></defs><clipPath id="b"><use xlink:href="#a" overflow="visible"></use></clipPath><path clip-path="url(#b)" d="M12 2C6.5 2 2 6.5 2 12s4.5 10 10 10 10-4.5 10-10S17.5 2 12 2zm4.2 14.2L11 13V7h1.5v5.2l4.5 2.7-.8 1.3z"></path></svg><a href="https://ameliaislandliving.com/fernandinabeach/2019/07/rolling-stones-mick-jagger-dines-downtown-at-espana/" rel="bookmark"><time class="entry-date published" datetime="2019-07-18T01:02:40-04:00">July 18, 2019</time><time class="updated" datetime="2019-07-18T01:03:45-04:00">July 18, 2019</time></a></span><span class="cat-links"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M10 4H4c-1.1 0-1.99.9-1.99 2L2 18c0 1.1.9 2 2 2h16c1.1 0 2-.9 2-2V8c0-1.1-.9-2-2-2h-8l-2-2z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg><span class="screen-reader-text">Posted in</span><a href="https://ameliaislandliving.com/fernandinabeach/topics/marketplace/" rel="category tag">Marketplace</a>, <a href="https://ameliaislandliving.com/fernandinabeach/topics/amelia-island-summer/" rel="category tag">Summer</a></span><span class="tags-links"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M21.41 11.58l-9-9C12.05 2.22 11.55 2 11 2H4c-1.1 0-2 .9-2 2v7c0 .55.22 1.05.59 1.42l9 9c.36.36.86.58 1.41.58.55 0 1.05-.22 1.41-.59l7-7c.37-.36.59-.86.59-1.41 0-.55-.23-1.06-.59-1.42zM5.5 7C4.67 7 4 6.33 4 5.5S4.67 4 5.5 4 7 4.67 7 5.5 6.33 7 5.5 7z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg><span class="screen-reader-text">Tags: </span><a href="https://ameliaislandliving.com/fernandinabeach/tag/restaurants/" rel="tag">"restaurants"</a>, <a href="https://ameliaislandliving.com/fernandinabeach/tag/amelia-island-news/" rel="tag">Amelia Island news</a>, <a href="https://ameliaislandliving.com/fernandinabeach/tag/dining/" rel="tag">dining</a>, <a href="https://ameliaislandliving.com/fernandinabeach/tag/espana/" rel="tag">Espana</a>, <a href="https://ameliaislandliving.com/fernandinabeach/tag/fernandina-beach/" rel="tag">fernandina beach</a>, <a href="https://ameliaislandliving.com/fernandinabeach/tag/mick-jagger/" rel="tag">Mick Jagger</a>, <a href="https://ameliaislandliving.com/fernandinabeach/tag/rolling-stones/" rel="tag">Rolling Stones</a></span></footer></article><nav class="navigation post-navigation" role="navigation"><h2 class="screen-reader-text">Post navigation</h2><div class="nav-links"><div class="nav-previous"><a href="https://ameliaislandliving.com/fernandinabeach/2019/07/cumberland-island-wildfire-contained/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous Post</span> <span class="screen-reader-text">Previous post:</span> <br /><span class="post-title">Cumberland Island Wildfire Contained</span></a></div></div></nav></main></section></div><footer id="colophon" class="site-footer"><aside class="widget-area" role="complementary" aria-label="Footer"><div class="widget-column footer-widget-1"><section id="nav_menu-20" class="widget widget_nav_menu"><h2 class="widget-title">See &#038; Do</h2><div class="menu-amelia-island-travel-guide-container"><ul id="menu-amelia-island-travel-guide" class="menu"><li id="menu-item-53284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53284"><a href="https://ameliaislandliving.com/fernandinabeach/amelia-island-travel-guide/">Top 3 Attractions</a></li><li id="menu-item-15477" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15477"><a href="https://ameliaislandliving.com/fernandinabeach/amelia-island-travel-guide/historic-district/">Downtown Fernandina</a></li><li id="menu-item-47959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47959"><a href="https://ameliaislandliving.com/fernandinabeach/beaches/">Beach Parks &#038; Laws</a></li><li id="menu-item-47653" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47653"><a href="https://ameliaislandliving.com/fernandinabeach/amelia-island-festivals-special-events-2011/">Festivals &#038; Top Events</a></li><li id="menu-item-15478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15478"><a href="https://ameliaislandliving.com/fernandinabeach/amelia-island-travel-guide/fort-clinch/">Fort Clinch State Park</a></li><li id="menu-item-29027" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29027"><a href="https://ameliaislandliving.com/fernandinabeach/amelia-island-state-park-florida/">Amelia Island State Park</a></li><li id="menu-item-15465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15465"><a href="https://ameliaislandliving.com/fernandinabeach/amelia-island-travel-guide/lighthouse/">Amelia Lighthouse</a></li><li id="menu-item-47960" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47960"><a href="https://ameliaislandliving.com/fernandinabeach/amelia-island-travel-guide/cumberland-island-georgia/">Cumberland Island, GA</a></li><li id="menu-item-47570" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-47570"><a href="https://ameliaislandliving.com/fernandinabeach/2017/06/floridas-a1a-ocean-islands-trail/">Ocean Islands Trail</a></li><li id="menu-item-45243" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45243"><a href="https://ameliaislandliving.com/fernandinabeach/explore-nearby-amelia-island/">Nearby Places To Explore</a></li><li id="menu-item-45711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45711"><a href="https://ameliaislandliving.com/fernandinabeach/topics/sea-turtle-nesting-amelia-island/">Sea Turtles</a></li><li id="menu-item-46294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46294"><a href="https://ameliaislandliving.com/fernandinabeach/amelia-island-travel-guide/amelia-island-weather-fernandina-beach/">Weather &#038; Webcam</a></li><li id="menu-item-47530" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47530"><a href="https://ameliaislandliving.com/fernandinabeach/isle-of-8-flags-shrimp-festival/">Shrimp Festival</a></li><li id="menu-item-47529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47529"><a href="https://ameliaislandliving.com/fernandinabeach/topics/amelia-concours-d-elegance-event-march/">Concours d&#8217;Elegance</a></li><li id="menu-item-49008" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49008"><a href="https://ameliaislandliving.com/fernandinabeach/dining/">Restaurants</a></li><li id="menu-item-42624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42624"><a href="https://ameliaislandliving.com/fernandinabeach/amelia-island-travel-guide/nightlife-2/">Pubs &#038; Beach Bars</a></li><li id="menu-item-52665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52665"><a href="https://ameliaislandliving.com/fernandinabeach/fernandina-beach-municipal-airport/">Closest Airport</a></li></ul></div></section><section id="recent-posts-3" class="widget widget_recent_entries"><h2 class="widget-title">News &#038; Views</h2><ul><li> <a href="https://ameliaislandliving.com/fernandinabeach/2019/07/rolling-stones-mick-jagger-dines-downtown-at-espana/">Rolling Stones&#8217; Mick Jagger Dines Downtown At Espana</a></li><li> <a href="https://ameliaislandliving.com/fernandinabeach/2019/07/cumberland-island-wildfire-contained/">Cumberland Island Wildfire Contained</a></li><li> <a href="https://ameliaislandliving.com/fernandinabeach/2019/07/2019-sea-turtle-nests-shatter-previous-record/">Sea Turtle Nests Shatter Previous Record</a></li><li> <a href="https://ameliaislandliving.com/fernandinabeach/2019/07/development-disputes-lawsuits-spark-fireworks/">Development Disputes, Lawsuits Spark Fireworks</a></li><li> <a href="https://ameliaislandliving.com/fernandinabeach/2019/06/fernandina-fireworks-festivities-july-4-2019/">Fernandina Fireworks &#038; Festivities July 4, 2019</a></li><li> <a href="https://ameliaislandliving.com/fernandinabeach/2019/06/cumberland-island-camping-tips/">Cumberland Island&#8217;s Five Campgrounds</a></li><li> <a href="https://ameliaislandliving.com/fernandinabeach/2019/06/what-is-this-caterpillar-gardening-q-a/">&#8216;Tis The Season For Caterpillars</a></li><li> <a href="https://ameliaislandliving.com/fernandinabeach/2019/06/amelia-island-lures-big-leaguers/">Amelia Island Lures Big Leaguers</a></li><li> <a href="https://ameliaislandliving.com/fernandinabeach/2019/05/kicking-off-summer-beach-season-2019/">Kicking Off Summer Beach Season 2019</a></li><li> <a href="https://ameliaislandliving.com/fernandinabeach/2019/05/second-amelia-island-beach-visitor-run-over/">Second Amelia Island Beach Visitor Run Over</a></li></ul></section><section id="search-2" class="widget widget_search"><h2 class="widget-title">Keyword Search</h2><form role="search" method="get" class="search-form" action="https://ameliaislandliving.com/fernandinabeach/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></section><section id="archives-6" class="widget widget_archive"><h2 class="widget-title">Articles</h2> <label class="screen-reader-text" for="archives-dropdown-6">Articles</label> <select id="archives-dropdown-6" name="archive-dropdown"><option value="">Select Month</option><option value='https://ameliaislandliving.com/fernandinabeach/2019/07/'> July 2019</option><option value='https://ameliaislandliving.com/fernandinabeach/2019/06/'> June 2019</option><option value='https://ameliaislandliving.com/fernandinabeach/2019/05/'> May 2019</option><option value='https://ameliaislandliving.com/fernandinabeach/2019/04/'> April 2019</option><option value='https://ameliaislandliving.com/fernandinabeach/2019/03/'> March 2019</option><option value='https://ameliaislandliving.com/fernandinabeach/2019/02/'> February 2019</option><option value='https://ameliaislandliving.com/fernandinabeach/2019/01/'> January 2019</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/12/'> December 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/11/'> November 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/10/'> October 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/09/'> September 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/08/'> August 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/07/'> July 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/06/'> June 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/05/'> May 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/04/'> April 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/03/'> March 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/02/'> February 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2018/01/'> January 2018</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/12/'> December 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/11/'> November 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/10/'> October 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/09/'> September 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/08/'> August 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/07/'> July 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/06/'> June 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/05/'> May 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/04/'> April 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/03/'> March 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/02/'> February 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2017/01/'> January 2017</option><option value='https://ameliaislandliving.com/fernandinabeach/2016/12/'> December 2016</option><option value='https://ameliaislandliving.com/fernandinabeach/2016/11/'> November 2016</option><option value='https://ameliaislandliving.com/fernandinabeach/2016/10/'> October 2016</option><option value='https://ameliaislandliving.com/fernandinabeach/2016/09/'> September 2016</option><option value='https://ameliaislandliving.com/fernandinabeach/2016/08/'> August 2016</option><option value='https://ameliaislandliving.com/fernandinabeach/2016/07/'> July 2016</option><option value='https://ameliaislandliving.com/fernandinabeach/2016/06/'> June 2016</option><option value='https://ameliaislandliving.com/fernandinabeach/2016/05/'> May 2016</option><option value='https://ameliaislandliving.com/fernandinabeach/2016/04/'> April 2016</option><option value='https://ameliaislandliving.com/fernandinabeach/2016/03/'> March 2016</option><option value='https://ameliaislandliving.com/fernandinabeach/2016/02/'> February 2016</option><option value='https://ameliaislandliving.com/fernandinabeach/2015/12/'> December 2015</option><option value='https://ameliaislandliving.com/fernandinabeach/2015/11/'> November 2015</option><option value='https://ameliaislandliving.com/fernandinabeach/2015/10/'> October 2015</option><option value='https://ameliaislandliving.com/fernandinabeach/2015/09/'> September 2015</option><option value='https://ameliaislandliving.com/fernandinabeach/2015/07/'> July 2015</option><option value='https://ameliaislandliving.com/fernandinabeach/2015/06/'> June 2015</option><option value='https://ameliaislandliving.com/fernandinabeach/2015/05/'> May 2015</option><option value='https://ameliaislandliving.com/fernandinabeach/2015/04/'> April 2015</option><option value='https://ameliaislandliving.com/fernandinabeach/2015/03/'> March 2015</option><option value='https://ameliaislandliving.com/fernandinabeach/2015/02/'> February 2015</option><option value='https://ameliaislandliving.com/fernandinabeach/2015/01/'> January 2015</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/12/'> December 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/11/'> November 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/10/'> October 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/09/'> September 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/08/'> August 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/07/'> July 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/06/'> June 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/05/'> May 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/04/'> April 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/03/'> March 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/02/'> February 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2014/01/'> January 2014</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/12/'> December 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/11/'> November 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/10/'> October 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/09/'> September 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/08/'> August 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/07/'> July 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/06/'> June 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/05/'> May 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/04/'> April 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/03/'> March 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/02/'> February 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2013/01/'> January 2013</option><option value='https://ameliaislandliving.com/fernandinabeach/2012/11/'> November 2012</option><option value='https://ameliaislandliving.com/fernandinabeach/2012/10/'> October 2012</option><option value='https://ameliaislandliving.com/fernandinabeach/2012/09/'> September 2012</option><option value='https://ameliaislandliving.com/fernandinabeach/2012/08/'> August 2012</option><option value='https://ameliaislandliving.com/fernandinabeach/2012/07/'> July 2012</option><option value='https://ameliaislandliving.com/fernandinabeach/2012/06/'> June 2012</option><option value='https://ameliaislandliving.com/fernandinabeach/2012/04/'> April 2012</option><option value='https://ameliaislandliving.com/fernandinabeach/2012/03/'> March 2012</option><option value='https://ameliaislandliving.com/fernandinabeach/2012/02/'> February 2012</option><option value='https://ameliaislandliving.com/fernandinabeach/2012/01/'> January 2012</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/12/'> December 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/11/'> November 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/10/'> October 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/09/'> September 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/08/'> August 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/07/'> July 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/06/'> June 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/05/'> May 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/04/'> April 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/03/'> March 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/02/'> February 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2011/01/'> January 2011</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/12/'> December 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/11/'> November 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/10/'> October 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/09/'> September 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/08/'> August 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/07/'> July 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/06/'> June 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/05/'> May 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/04/'> April 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/03/'> March 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/02/'> February 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2010/01/'> January 2010</option><option value='https://ameliaislandliving.com/fernandinabeach/2009/12/'> December 2009</option><option value='https://ameliaislandliving.com/fernandinabeach/2009/11/'> November 2009</option><option value='https://ameliaislandliving.com/fernandinabeach/2009/10/'> October 2009</option> </select></section></div></aside><div class="site-info"> <a class="site-name" href="https://ameliaislandliving.com/fernandinabeach/" rel="home">Amelia Island Living ©2019</a>, <a href="https://wordpress.org/" class="imprint"> Proudly powered by WordPress. </a> <a class="privacy-policy-link" href="https://ameliaislandliving.com/fernandinabeach/terms-of-use/">Website Terms. Privacy. Contact Us.</a><span role="separator" aria-hidden="true"></span><nav class="footer-navigation" aria-label="Footer Menu"><div class="menu-top-navigation-container"><ul id="menu-top-navigation-1" class="footer-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51535"><a href="https://ameliaislandliving.com/fernandinabeach/topics/amelia-island-beach/">Beach News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51536"><a href="https://ameliaislandliving.com/fernandinabeach/topics/downtown-fernandina/">Downtown Topics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40662"><a href="https://ameliaislandliving.com/fernandinabeach/topics/marketplace/">BIZ News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19041"><a href="https://ameliaislandliving.com/fernandinabeach/topics/nature/">Nature</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47958"><a href="https://ameliaislandliving.com/fernandinabeach/topics/cumberland-island-georgia/">Cumberland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40661"><a href="https://ameliaislandliving.com/fernandinabeach/topics/garden/">Garden</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51512"><a href="https://ameliaislandliving.com/fernandinabeach/topics/amelia-island-perspective/">Perspective</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48687"><a href="https://ameliaislandliving.com/fernandinabeach/topics/amelia-island-real-estate/">Real Estate</a></li></ul></div></nav></div></footer></div> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KQHVM5M"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-11941575-1', 'auto');
  ga('send', 'pageview');</script> <script type="text/javascript" defer src="https://ameliaislandliving.com/fernandinabeach/wp-content/cache/autoptimize/autoptimize_314f149ff547fb996a11dbe192d54562.php"></script></body></html>
